
 

FAQ  

Properties 

How do I change the properties of the software? 

Click the “Options” tab on the toolbar, then click the “Properties” button from the dropdown. This will 

open up the properties window. 

 

What properties can I change? 

Within the properties window, you can change seven different types of properties. These types of 

properties are as follows: 

1. The path of SAL binary (there is no default value for this property). Click the “…” button 

next to the input text field in order to select a path via your file directory system. 

2. The path of Cygwin bash (there is no default value for this property). Click the “…” button 

next to the input text field in order to select a path via your file directory system. 

3. The Out directory of .sal files (the default value for this property is 

C:\Users\”USERNAME”\AppData\Roaming\AlarmMasking\out). Click the “…” button next 

to the input text field in order to select a path via your file directory system. 

4. The default spread for new events (this is the default value the spread parameter will have for 

the event that is added to an Alarm when the “Add an Event” button is clicked) 

5. The default volume for new events (this is the default value the volume parameter will have 

for the event that is added to an Alarm when the “Add an Event” button is clicked) 

5a.  Default volume for Low Priority events 

5b.  Default volume for Medium Priority events 

5c.  Default volume for High Priority events 
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6. The Alpha level (this is the alpha level value to be used when any model checking is 

executed; the default value for this property is 0.33) 

7. The language of the program (MAASC currently supports English and French) 

 

 

Modeling a configuration of alarms 

How do I create a new configuration of alarms? 

Click the “File” tab on the toolbar, then click the “New” button from the dropdown. Warning: this will 

erase your current configuration. 

 

How do I load an existing configuration? 



Click the “File” tab on the toolbar, then click the “Load Alarms from Configuration file” button from the 

dropdown. Warning: this will replace your current configuration. 

 

How do I import Alarms into the current configuration? 

Click the “File” tab on the toolbar, then click the “Add Alarms from Configuration file” button from the 

dropdown. This will keep your current configuration and append the Alarms from the file you load into 

your current configuration. 

 

How do I save my current configuration? 

Click the “File” tab on the toolbar, then click the “Save” button from the dropdown. This will override the 

named configuration file you are currently working with. 



 

How do I save my current configuration as a new named configuration file? 

Click the “File” tab on the toolbar, then click the “Save As” button from the dropdown. This will open a 

directory window and allow you to name and save the configuration you are currently working with as a 

new file in the destination of your choosing.  

 

Modeling Alarms in a Configuration 

How do I add an alarm to the current configuration? 

Click the “Edit” tab on the toolbar, then click the “Add an Alarm” button from the dropdown. This will 

add a new Alarm to your current configuration. The parameters of this new alarm will be populated with 

default values specified by your properties settings. 



 

How do I delete an alarm from the current configuration? 

Click the “Edit” tab on the toolbar, then click the “Delete Selected Alarm” button from the dropdown. 

This will delete the Alarm currently selected from your current configuration. 

 

How do I copy and paste alarms? 

To copy an alarm, click the “Edit” tab on the toolbar, then click the “Copy an Alarm” button from the 

dropdown. This will copy the Alarm currently selected from your current configuration. NOTE: If 

multiple Alarms are selected, then clicking the “Copy an Alarm” button will copy all of the currently 

selected alarms to your clipboard. 

 



To paste the alarm that is copied to your clipboard, click the “Edit” tab on the toolbar, then click the 

“Paste an Alarm” button from the dropdown. This will paste the Alarm’s currently copied to your 

clipboard. NOTE: The order which Alarms are selected for copying will not necessarily be preserved 

when they are pasted. Once Alarms are pasted the user can manually move around alarms for 

organization purposes. 

 

How do I play the audio of an alarm? 

In order to play an Alarm and listen to the sounds you have modeled, click the play button associated with 

the Alarm you want to hear. This will play through all of the Events that belong to that Alarm. You can 

only listen to one Alarm at a time (you cannot play any other Alarms while an Alarm is currently 

playing). In the example image below, clicking the indicated play button will play through all three of the 

Events belonging to the Alarm named “Oxygen” 

 

What attributes of an Alarm can I edit? 

There are four attributes of an Alarm which are editable. In the example below, the bordered text fields 

are the attributes which you can edit for a given Alarm. The first of these four attributes is the name of the 

Alarm. This is how the Alarm will be referenced when any model checking procedures are executed. The 

other three attributes are parameters of the Alarm: Default Volume in decibels, Default Tone Duration in 

seconds, and Default Tone Spacing in hertz. These parameters will dictate the default values for Events 

that belong to an Alarm. The Priority attribute must be specified before adding a new Alarm to your 

configuration.  



 

 How do I edit the attributes of an alarm? 

You can edit attributes by double clicking in the text field corresponding to the attribute you want to edit. 

This will color the cell background white and bring up a blinking cursor denoting the value is now being 

edited. Once you have entered a valid value and are done editing, press enter to confirm the new value. If 

you have entered an invalid value, the application will let you know and prompt you to correct the value 

to a valid one before confirming the edit. 

 

How do I randomly generate alarm parameter values? 

To randomly generate values for Alarm parameters, click the “Edit” tab on the toolbar, then click the 

“Generate Values” button from the dropdown. NOTE: The Alarm parameters which values will be 

randomly generated for are “Default Tone Duration” as well as “Default Tone Spacing”. When parameter 

values are randomly generated, the Events of Alarms will be automatically updated to match these 

changes in parameter values. 



 

Events 

How do I access the events of different alarms for editing? 

An alarm is a collection of alarm events, where each event has a tone (with a duration) followed by a 

pause (also followed by a duration, which can be 0). 

Selecting the alarm in the top table will automatically display the events that belong to it in the bottom 

table. You can then edit any of the editable attributes of these Events. 

 

How many event/s should an alarm have? 

The number of Event/s that an Alarm should have is determined by what the Priority of the Alarm is. This 

priority is set when you add a new Alarm to your configuration. There are four levels of Priority which 

are listed below in ascending order. Listed next to each Priority level is the number of Events that an 

Alarm with that Priority level should have: 

Priority      :       # of Events      

Low (1)     :       One 

Low (2)     :       Two 

Medium    :       Three 



High         :        Ten 

What attributes of an event can I edit? 

There are five attributes of an Event which are editable. In the example below, the bordered text fields are 

the attributes which you can edit for a given Event. The “Time” attribute denotes how long the event 

lasts; the unit for this attribute is seconds. The “Tone” attribute denotes the frequency of the Event the 

unit of this attribute is hertz. The “Volume” attribute denotes how loud the Event is; the unit of this 

attribute is decibels. The “Spread” attribute denotes the spreading function used for the event in the 

execution of formal model checking procedures. The “Spacing After” attribute denotes the time until the 

next Event occurs after the current event; the unit of this attribute is in seconds.  

 

How do I edit the attributes of an event? 

You can edit attributes by double clicking in the text field corresponding to the attribute you want to edit. 

For the “Time”, “Volume”, and “Spacing After” attributes, this will color the cell background white and 

bring up a blinking cursor denoting the value is now being edited. For the “Tone” and “Spread” attributes, 

this will also bring up a dropdown of some commonly used, pre-specified values (however, you can enter 

any value you want into the text field as long as it is valid for that attribute). Once you have entered a 

valid value and are done editing, press enter to confirm the new value. If you have entered an invalid 

value, the application will let you know and prompt you to correct the value to a valid one before 

confirming the edit. 

 

Why are some event attribute values bold and italic? 



When an Event attribute value does not conform to what the default value for that attribute should be for 

an Alarm, the application will alert you by bolding and italicizing the Event attribute value. In the 

example below, the value for “Default Tone Spacing” for the Alarm named Oxygen is 0.2 seconds. 

However, not all of the Events that comprise the Oxygen Alarm adhere to this value 0.2 seconds. The 

Events which do adhere to this value (ie. are also at a value of 0.2 seconds) appear in normal font, 

whereas the Events which do not adhere to this value (ie. are set at a value other than 0.2 seconds) are 

shown both italicized and bolded. NOTE: The value for the “Spacing After” attribute for the last Event of 

an Alarm does NOT have to adhere to the default value specified for an Alarm. This is the sole exception 

to the rule. 

 

How do I delete an event? 

In order to delete an event, navigate to the Event you want to delete and click the button with the trash can 

on it in the far right column titled “Delete”. NOTE: This will permanently delete this Event from its 

Alarm.  

 

Analysis – Checking a Modeled Configuration for Masking 

How can I formally check for auditory masking? 

In order to formally check for auditory masking, navigate to the “Analysis” tab on the toolbar and click 

the “Check for Masking” button. This will bring up the model checking calibration window. 



 

How can I calibrate my formal check for auditory masking? 

Once you bring up the model checking calibration window, you can calibrate your formal check in terms 

of selecting which Alarms you are checking for masking. Additionally, you can select which types of 

masking you want to check for: total masking, partial masking, or both total and partial masking. Simply 

check the boxes next to the feature you want to include in your formal check for auditory masking to 

include it. By default, all boxes are checked, which means that all Alarms in your current configuration 

are included in a formal check for both partial and total auditory masking. NOTE: In general, checking 

for total masking is more computationally intensive than partial masking. ADDITIONAL NOTE: The 

formal check will be conducted using the Alpha level you have specified in the properties menu (the 

default Alpha level value unless manually changed is 0.33). 

 

What does the masking analysis show? 

The analysis window contains several items of interest. For each Alarm in your configuration that was 

included in the analysis run, you will see a row (or two rows, one for total masking and one for partial 

masking if both were selected) summarizing an auditory masking checking procedure. In each row, you 

will have columns with the following information: 



The “id” column denotes the number of the formal checking procedure that was run. The “Status” column 

denotes the status of the given formal checking procedure. The “Maskee” column denotes which Alarm 

(referred to by the name you have set in your configuration) is being checked for masking in the given 

formal checking procedure, the “Info” column relays any important information to the user outside of 

what is generated from SAL. The “Type” column denotes which type of formal checking procedure was 

being conducted. The “Message” column relays a brief linguistic summary of the results of the formal 

checking procedure that was conducted. The “Time” column displays the length of time the formal 

checking procedure has been running/took to run.  

 

What can I do at the end of an analysis? 

The three rightmost columns each contain buttons labeled which denote their function. Clicking a button 

labeled “Visualize” will open a graphic visualization of a counterexample demonstrating the type of 

masking that was formally checked for. NOTE: This button will only appear in rows where a violation 

was found in the formal checking procedure. 

 Clicking a button labeled “Results” will open a file that includes output information from SAL for the 

formal checking procedure.  

Clicking a button labeled “Diagnostics” will open a file that includes information from SAL describing 

the formal checking procedure that can be used to diagnose bugs or errors should one be found, as well as 

the computational process SAL executes. 

 

How can I export my results? 

In the “Analysis” window that opens when you run a formal check for masking, click the “File” tab and 

then click the “Save” button. This will open your file directory and allow you to name and save a time-

stamped CSV file containing a summary of the information displayed in the “Analysis” window to a 

location of your choosing. 



 

How can I look at the models that were analyzed by the model checker (SAL files)? 

You can manually browse all of the .out and .sal files produced for/from your analyses in the SAL 

directory itself:  

    C:\Users\**USERNAME**\AppData\Roaming\AlarmMasking\out                                                         

You can open this file location by clicking the “File” tab and then click the “Open SAL directory” button 

in the “Analysis” window that opens when you run a formal check for masking. 

 

Analysis – Checking Compliance with the IEC 60601-1-8 International Medical Alarm Standard 

How can I check if my configuration is compliant to the standard? 

Navigate to the “Analysis” tab on the toolbar and click the “Check Standard Compliance” button, this will 

execute the standard checking tool.  



 

What does the standard checker look for? 

The standard checker looks for any deviations from the current International Medical Alarm Standards 

that the Alarms and Events in your current configuration may have. Additionally, the standard checker 

will find any errors you have for Event attribute values resulting from deviations from the default values 

you have set for the Alarm they belong to. This makes the Standard checker a stellar tool for ensuring that 

your configuration is of sound structure before you begin running formal checks for auditory masking. 

What does the standard checker output? 

The standard checker window that is opened upon running the standard checker will contain a number of 

rows which each have five columns. Each row represents an issue of interest that the Standard checker 

tool has identified. The “id” column denotes the number of the issue of interest. The “Type” column 

denotes what type of issue was identified. The “Name” column denotes the name of the type of issue 

identified. For example, “Volume of an event” is the name of a type of “Error” issue. The “Source” 

column denotes where the issue of interest is located. The “Message” column relays information specific 

to correcting the issue identified. 

 

How can I use the information given by the standard checker to correct my configuration in order 

to be compliant to IEC 60601-1-8? 



Using the information in the “Source” and “Message” columns, you can identify where an issue with your 

configuration is, as well as how to correct that issue. Simply navigate to where the “Source” column tells 

you the issue is located within your current configuration, and then manually correct the issue by 

following the constraints and/or instructions provided by the information in the “Message” column. 

How to export the output of the Standard checker? 

In the “Check Norm Compliance” window that opens when you run the Standard checker, click the “File” 

tab and then click the “Save” button. This will open your file directory and allow you to name and save a 

time-stamped CSV file containing a summary of the information displayed in the “Check Norm 

Compliance” window to a location of your choosing. 

 

Analysis – Parameter Exploration 

What is parameter exploration? 

The parameter exploration tool allows you to examine the effects of incrementing certain attributes of a 

specific alarm event. By using this tool, you can identify all values within a given range at given intervals 

for a specific attribute that eliminate auditory masking. Essentially, the tool runs a formal check for every 

value iteration of the parameter you are exploring. 

How do IU 

arameter Exploration tool, navigate to the “Analysis” tab on the toolbar, and then click the “Parameter 

Exploration” button. This will bring up the “Parameter Exploration” window, which is where you will 

calibrate your execution of the Parameter Exploration tool. 

 



What parameters can I explore? 

You can explore four parameters. These parameters are four different attributes of Events. Tone Duration 

(seconds), Tone Spacing (seconds), Volume (decibels), and Frequency (hertz). For each of these four 

attributes, you can set three values which will determine how many formal check iterations will be 

executed and with what parameter values. The minimum value determines the starting value for the 

attribute in question and will be the first iteration. The step value determines how much the value will 

increase for the following iteration. The maximum value determines the final value for the attribute in 

question and will be the final iteration. Similar to running a regular formal check for acoustic masking, 

you can also check the boxes at the top of the “Parameter Exploration” window to set which kind/s of 

masking will be getting checked for. You can select total masking and/or partial masking. 

 

What does the analysis show? 

The Analysis window contains several items of interest. For each iteration that was run as a result of the 

values you set for the attribute you are examining with the Parameter Exploration tool, you will see a row 

(or two rows, one for total masking and one for partial masking if both were selected) for each iteration 

summarizing an auditory masking checking procedure. In each row, you will have columns with the 

following information: 

The “id” column denotes the number of the formal checking procedure that was run. The “Status” column 

denotes the status of the given formal checking procedure. The “Maskee” column denotes which Alarm 

(referred to by the name you have set in your configuration) is being checked for masking in the given 

formal checking procedure, the “Info” column relays any important information to the user outside of 

what is generated from SAL. The “Type” column denotes which type of formal checking procedure was 

being conducted. The “Message” column relays a brief linguistic summary of the results of the formal 

checking procedure that was conducted. The “Time” column displays the length of time the formal 

checking procedure has been running/took to run.  



 

What can I do at the end of the parameter exploration? 

After your execution of the Parameter Exploration tool, you can do a few different things, three of which 

can be accessed through the buttons in the rightmost columns. The three rightmost columns each contain 

buttons labeled which denote their function. Clicking a button labeled “Visualize” will open a graphic 

visualization of a counterexample demonstrating the type of masking that was formally checked for. 

NOTE: This button will only appear in rows where a violation was found in the formal checking 

procedure. 

 Clicking a button labeled “Results” will open a file that includes output information from SAL for the 

formal checking procedure.  

Clicking a button labeled “Diagnostics” will open a file that includes information from SAL describing 

the formal checking procedure that can be used to diagnose bugs or errors should one be found, as well as 

the computational process SAL executes. 

How can I export my results? 

In the “Analysis” window that opens when you execute the Parameter Exploration tool, click the “File” 

tab and then click the “Save” button. This will open your file directory and allow you to name and save a 

time-stamped CSV file containing a summary of the information displayed in the “Analysis” window to a 

location of your choosing. 



 

 

Known bugs 

- Deleting the last alarm with the column button results in a freeze 

 


